pytanie zadane 8 stycznia 2019 w Internet przez użytkownika anonimowy

Mam problem z EPUAPem. Nie chce mi dodać nowego załącznika do wysyłanego dokumentu. Gdy klikam zielony plusik, to po chwili zamiast dodać okienko do załączania pliku, wyskakuje błąd:

Exception in client-site code

Spróbuj przeładować stronę - aby to zrobić użyj kombinacji CTRL+F5.

  • Message: Cannot read property 'nextSibling' of null

 błąd załącznika w epuap

Próbuje wysyłać poprzez przeglądarkę Microsoft Edge, czy może ona jest przyczyną błędu?

1 odpowiedź

odpowiedź 10 stycznia 2019 przez użytkownika

Błąd przy dołączaniu załączników przy wysyłaniu pisma przez Epuap, może pojawić się właśnie w przeglądarce Microsoft Edge, gdy masz starszą wersję.

Sprawdź w ustawieniach jaką masz wersję przeglądarki. Powinna być najlepiej najnowsza w wersja 44.17763.1.0

wersja przeglądarki microsoft edge

Przeglądarka Edge powinna się zaktualizować automatycznie podczas aktualizacji systemu Windows. Jeśli masz starszą wersję, możesz wymusić aktualizacje wchodząc w START -> Ustawienia -> Aktualizacja i zabezpieczenia i kliknij przycisk Sprawdź aktualizacje

Po aktualizacji przeglądarki, warto jeszcze wyczyścić tymczasowe pliki internetowe i teraz sprawdzić czy działa dodawanie załączników przez EPUAP.


Edycja 1.07.2020

Ostatnio w komentarzach piszecie, że jest problem z dodaniem załączników pod jakąkolwiek z przeglądarek. Rzeczywiście problem występuje i niektórych użytkowników.

Rozwiązaniem może być dodanie załącznika w trochę inny sposób. Trzeba wejść w Robocze i w prawym górnym rogu znajduje się przycisk + Dodaj plik z dysku. Po kliknięciu od razu wskazuje się plik, który chcesz wysłać EPUAPem. Poniżej tworzy się automatycznie wiadomość z nazwą załącznika.

Minusem tego rozwiązania, jest to że można za jego pomocą dodać tylko jeden plik (załącznik), a cała wiadomość zostanie wysłana z ogólnego szablonu, jako Ogólne pismo do urzędu. Ale za skutecznie można załączyć plik i wysłać dokument.


Edycja 08.06.2021

Kolejnym rozwiązaniem problemu z załącznikami, jest ich uprzednie dodanie do zasobów plikowych skrzynki. W tym celu wchodzisz w lewym menu w opcję Moje pliki i tutaj wybierasz załączniki do dodania z dysku i następnie klikasz wgraj. Po wgraniu załączników na serwer, wchodzisz w Robocze i wysyłaną wiadomość i tam załączasz plik, już nie wgrywając ich z dysku, tylko wybierając z gotowych plików na serwerze.


Jeśli tworzymy pismo przez Robocze (wyżej opisane), i jeśli mamy problem z dodaniem drugiego załącznika w PDF, to najlepiej jest zrobić to w inny sposób. Wystarczy plik podpisać jako PADES, czyli wewnętrzny podpis w pliku PDF i wtedy nie będzie dwóch plików (plik źródłowy + plik z podpisem), tylko jeden plik zawierający i to i to. Wtedy załącznik dodasz od razu przez Robocze i nie będzie potrzeby dodawania drugiego. 

komentarz 11 stycznia 2019 przez użytkownika anonimowy

Dziękuje, pomogło!! Miałem starą wersję przeglądarki edge 42.17134.1.0

Gdy zaktualizowałem do najnowszej tak jak radziłeś, złączniki w epuapie poprawnie się ładują.

komentarz 1 lutego 2019 przez użytkownika anonimowy

Mam ten sam problem, tylko że Chrome - najnowsza wersja i ten sam problem 72.0.3626.81

komentarz 1 kwietnia 2020 przez użytkownika anonimowy
mam ten sam problem z chrome
komentarz 24 maja 2020 przez użytkownika anonimowy
W najnowszej edge też nie działa. W Chrome też nie działa.
komentarz 24 maja 2020 przez użytkownika
Proponuje jeszcze sprawdzić w Firefoksie i Operze. Może to śmieszne, ale czasami w jednej przeglądarce potrafi działać, a w drugiej nie.
komentarz 16 czerwca 2020 przez użytkownika anonimowy
W chrome {Version 83.0.4103.97 (Official Build) (64-bit)} jest to samo.
komentarz 17 czerwca 2020 przez użytkownika anonimowy
zależy jeszcze o jakiej godzinie się wysyła, zauważyłem że najlepiej wieczorem lub w nocy
komentarz 17 czerwca 2020 przez użytkownika anonimowy

Najnowsza i aktualna wersja MS Edge (na aktualnym Chome również) - ten sam problem. Zgłasza ( MS Edge)  "Message: Cannot read property 'nextSibling' of null".  

komentarz 17 czerwca 2020 przez użytkownika anonimowy
Hej, miałem podobny błąd (17-06-2020) - jest to wina aplikacji formularza, która nie chce współpracować z żadną współczesną przeglądarką (Chrome, Edge, Firefox). Rozwiązaniem jest skorzystanie z Internet Explorer. Ja użyłem IE11 i byłem w stanie dodać załącznik. Pozdrawiam
komentarz 18 czerwca 2020 przez użytkownika anonimowy
Coś jest nie tak z tymi załącznikami od pewnego czasu. Ja próbowałem na wszystkich możliwych przeglądarkach i jest to samo. W końcu się udało ale straciłem mnóstwo czasu i nerwów. Chyba nie tak to powinno działać  żeby jeden, czy dwa załączniki dodawać godzinę.
komentarz 22 czerwca 2020 przez użytkownika anonimowy
Żadna przeglądarka nie obsługuje załączników: Edge, Chrome, Opera.

Próbowałem na różnych urządzeniach. Bezskutecznie.
komentarz 22 czerwca 2020 przez użytkownika anonimowy
U mnie również nie działa ta funkcja na przeglądarce Chrome. Natomiast co ciekawe, działa połowicznie na przeglądarce Internet Explorer - pokazuje się okienko dialogowe dodawania pliku, nawet po dodaniu dostaję komunikat "Plik został zapisany na serwerze", ale jednak pliku wcale nie ma.
komentarz 23 czerwca 2020 przez użytkownika anonimowy
Czy coś już wiadomo w kwestii epuap-u? Coś się dzieje czy jak. U mnie nie działa na żadnej przeglądarce. Win 10. U znajomej na win 7 chodzi, a na win 10 nie.
komentarz 24 czerwca 2020 przez użytkownika anonimowy
To nie wina epuap-u. Do tej pory wysyłałam ze wszystkich przeglądarek, od paru dni załączniki idą tylko z Firefoksa, spróbujcie.
komentarz 29 czerwca 2020 przez użytkownika anonimowy
U mnie na żadnej przeglądarce się nie dodają. Dopiero za którymś razem się udaje ale nie da się tak przecież pracować.
komentarz 30 czerwca 2020 przez użytkownika anonimowy
Zadna z przegladarek: Edge, Chrome, Opera nie obsluguje zalaczników, buuuuuuuuuuuuu, stracilam ok. 20h. Tylko Firefox !!!
komentarz 1 lipca 2020 przez użytkownika anonimowy
Nic nie działa, 2 dzień walczę i tracę czas.. próbowałam wszystkich przeglądarek. Na firefox niby się ładuje a koniec końców załączników brak :(
komentarz 9 lipca 2020 przez użytkownika anonimowy
Używam przeglądarki Vivaldi i o dziwo wszystko działa. Pod Chrome niestety nadal kicha.
komentarz 30 lipca 2020 przez użytkownika anonimowy
Potwierdzam, że tylko na Mozilli Firefox da się prawidłowo dodać załącznik. Opera, Edge, Vivaldi nie poradziły sobie z tym zadaniem. Dzięki za poradę, jedna więcej ode mnie - jeśli zapisujecie formularz, to sprawdzajcie to co zostało zapisane, potrafią się wkraść błędy.
komentarz 2 sierpnia 2020 przez użytkownika anonimowy
Również spróbowałam dzisiaj przez Firefox'a i poszło wszystko odrazu. Na chrome próbowałam X razy i się nie udało.
komentarz 4 sierpnia 2020 przez użytkownika anonimowy
Nie próbujcie niczego innego, od razu Firefox, działa :)
komentarz 26 kwietnia 2021 przez użytkownika anonimowy
dzisiaj te same problemy :(
komentarz 27 kwietnia 2021 przez użytkownika anonimowy
w ogóle nie działa e-puap, a infolinia zapchana, na maile nie odpowiadają... co to ma być?
komentarz 6 maja 2021 przez użytkownika anonimowy
na maile czasem odpowiadają...po kilku dniach:( i proszą o więcej szczegółów

dzisiaj też PORAŻKA:(
komentarz 19 maja 2021 przez użytkownika anonimowy
Na firefoxie też nie zawsze wchodzą załączniki, trzeba najpierw dodać osobno do folderu "moje pliki" a potem stamtąd wczytać  

PS. NIECH KTOŚ TO NAPRAWI BO JUŻ ROK JEST TEN SAM PROBLEM!
komentarz 12 kwietnia 2022 przez użytkownika anonimowy
Jeśli naprawa błędu jest jakąś nadludzką niemożliwą czynnością to czy nie można byłoby poinformować użytkowników na stronie głównej czy wyskakującym komunikatem, że system działa tylko na przeglądarce Firefox? Żeby nie trzeba było tracić czasu, wypróbowując wszystkie opcje dołączenia załącznika? Ręce opadają, a problem jak widać po komentarzach trwa już długo...
...